#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<year>\d{4})(?<month>\d{1,2})(?<day>\d{1,2})"
Local $sString = "19911231"
Local $sSubst = "${year}-${month}-${day}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)