use strict;
my $str = '19911231';
my $regex = qr/(?<year>\d{4})(?<month>\d{1,2})(?<day>\d{1,2})/mp;
my $subst = '${year}-${month}-${day}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";