import Foundation
let pattern = #"(?<year>\d{4})(?<month>\d{1,2})(?<day>\d{1,2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"19911231"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${year}-${month}-${day}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)