using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<year>\d{4})(?<month>\d{1,2})(?<day>\d{1,2})";
string substitution = @"${year}-${month}-${day}";
string input = @"19911231";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}