#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?=[^{]|^)| )\{\{\s*([Uu]ncat(egori[sz]ed)?|[Nn]ocat|[Nn]eedscategory|[Cc]ategori[sz]e)[^}]*\}\}"
Local $sString = "{{nocat}}" & @CRLF & _
"{{nocat|}}" & @CRLF & _
"{{{nocat}}}" & @CRLF & _
"{{{nocat|}}}" & @CRLF & _
"{{{nocat|yes}}}" & @CRLF & _
"{{{nocat|true}}}" & @CRLF & _
"{{{nocat|<noinclude>1</noinclude>}}}" & @CRLF & _
" {{nocat}}" & @CRLF & _
" {{uncat}}" & @CRLF & _
" {{uncategorized}}" & @CRLF & _
" {{uncategorised}}" & @CRLF & _
" {{nocat}}" & @CRLF & _
" {{uncat}}" & @CRLF & _
" {{uncategorized}}" & @CRLF & _
" {{uncategorised}}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")