re = /((?=[^{]|^)| )\{\{\s*([Uu]ncat(egori[sz]ed)?|[Nn]ocat|[Nn]eedscategory|[Cc]ategori[sz]e)[^}]*\}\}/m
str = '{{nocat}}
{{nocat|}}
{{{nocat}}}
{{{nocat|}}}
{{{nocat|yes}}}
{{{nocat|true}}}
{{{nocat|<noinclude>1</noinclude>}}}
{{nocat}}
{{uncat}}
{{uncategorized}}
{{uncategorised}}
{{nocat}}
{{uncat}}
{{uncategorized}}
{{uncategorised}}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end