import re
regex = re.compile(r"((?=[^{]|^)| )\{\{\s*([Uu]ncat(egori[sz]ed)?|[Nn]ocat|[Nn]eedscategory|[Cc]ategori[sz]e)[^}]*\}\}", flags=re.MULTILINE)
test_str = ("{{nocat}}\n"
"{{nocat|}}\n"
"{{{nocat}}}\n"
"{{{nocat|}}}\n"
"{{{nocat|yes}}}\n"
"{{{nocat|true}}}\n"
"{{{nocat|<noinclude>1</noinclude>}}}\n"
" {{nocat}}\n"
" {{uncat}}\n"
" {{uncategorized}}\n"
" {{uncategorised}}\n"
" {{nocat}}\n"
" {{uncat}}\n"
" {{uncategorized}}\n"
" {{uncategorised}}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")