use strict;
my $str = '{{nocat}}
{{nocat|}}
{{{nocat}}}
{{{nocat|}}}
{{{nocat|yes}}}
{{{nocat|true}}}
{{{nocat|<noinclude>1</noinclude>}}}
{{nocat}}
{{uncat}}
{{uncategorized}}
{{uncategorised}}
{{nocat}}
{{uncat}}
{{uncategorized}}
{{uncategorised}}
';
my $regex = qr/((?=[^{]|^)| )\{\{\s*([Uu]ncat(egori[sz]ed)?|[Nn]ocat|[Nn]eedscategory|[Cc]ategori[sz]e)[^}]*\}\}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}