const regex = /((?=[^{]|^)| )\{\{\s*([Uu]ncat(egori[sz]ed)?|[Nn]ocat|[Nn]eedscategory|[Cc]ategori[sz]e)[^}]*\}\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?=[^{]|^)| )\\{\\{\\s*([Uu]ncat(egori[sz]ed)?|[Nn]ocat|[Nn]eedscategory|[Cc]ategori[sz]e)[^}]*\\}\\}', 'gm')
const str = `{{nocat}}
{{nocat|}}
{{{nocat}}}
{{{nocat|}}}
{{{nocat|yes}}}
{{{nocat|true}}}
{{{nocat|<noinclude>1</noinclude>}}}
{{nocat}}
{{uncat}}
{{uncategorized}}
{{uncategorised}}
{{nocat}}
{{uncat}}
{{uncategorized}}
{{uncategorised}}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}