using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[A-Z0-9]{8} ){7}[A-Z0-9]{8}";
string input = @"1N2HY4C9 4JVNFYL8 4NCYTI84 12345678 QWERTYUI ASDFGHJK ZXCVBNMH QAZXSWED
PPOIUYTR 09876543 THNMJUIK MNBVCXZA 12345678 WDFGTYHJ TGBNHYTR QWERDDE3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}