package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[A-Z0-9]{8} ){7}[A-Z0-9]{8}`)
var str = `1N2HY4C9 4JVNFYL8 4NCYTI84 12345678 QWERTYUI ASDFGHJK ZXCVBNMH QAZXSWED
PPOIUYTR 09876543 THNMJUIK MNBVCXZA 12345678 WDFGTYHJ TGBNHYTR QWERDDE3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}