re = /(?:[A-Z0-9]{8} ){7}[A-Z0-9]{8}/m
str = '1N2HY4C9 4JVNFYL8 4NCYTI84 12345678 QWERTYUI ASDFGHJK ZXCVBNMH QAZXSWED
PPOIUYTR 09876543 THNMJUIK MNBVCXZA 12345678 WDFGTYHJ TGBNHYTR QWERDDE3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end