import re
regex = re.compile(r"(?:[A-Z0-9]{8} ){7}[A-Z0-9]{8}", flags=re.MULTILINE)
test_str = ("1N2HY4C9 4JVNFYL8 4NCYTI84 12345678 QWERTYUI ASDFGHJK ZXCVBNMH QAZXSWED\n"
"PPOIUYTR 09876543 THNMJUIK MNBVCXZA 12345678 WDFGTYHJ TGBNHYTR QWERDDE3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")