import Foundation
let pattern = #"(?:[A-Z0-9]{8} ){7}[A-Z0-9]{8}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1N2HY4C9 4JVNFYL8 4NCYTI84 12345678 QWERTYUI ASDFGHJK ZXCVBNMH QAZXSWED
PPOIUYTR 09876543 THNMJUIK MNBVCXZA 12345678 WDFGTYHJ TGBNHYTR QWERDDE3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)