# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=CHEM|HIST)\s*|(?<=MATHS)\s*/<A-WHITE-SPACE>/gm;t' <<< "CLASS 8B CHEM | MON | 10AM to 10:40AM
--Rescheduled-- CLASS 8B MATHS | MON | 11AM to 11:40AM
CLASS 8B HIST | MON | 5PM to 5:40PM'
CLASS 8B CHEM | MON | 10AM to 10:40AM
"