#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=CHEM|HIST)\s*|(?<=MATHS)\s*"
Local $sString = "CLASS 8B CHEM | MON | 10AM to 10:40AM" & @CRLF & _
"--Rescheduled-- CLASS 8B MATHS | MON | 11AM to 11:40AM" & @CRLF & _
"CLASS 8B HIST | MON | 5PM to 5:40PM'" & @CRLF & _
"CLASS 8B CHEM | MON | 10AM to 10:40AM" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "<A-WHITE-SPACE>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)