use strict;
my $str = 'CLASS 8B CHEM | MON | 10AM to 10:40AM
--Rescheduled-- CLASS 8B MATHS | MON | 11AM to 11:40AM
CLASS 8B HIST | MON | 5PM to 5:40PM\'
CLASS 8B CHEM | MON | 10AM to 10:40AM
';
my $regex = qr/(?<=CHEM|HIST)\s*|(?<=MATHS)\s*/mp;
my $subst = '<A-WHITE-SPACE>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";