$re = '/(?<=CHEM|HIST)\s*|(?<=MATHS)\s*/m';
$str = 'CLASS 8B CHEM | MON | 10AM to 10:40AM
--Rescheduled-- CLASS 8B MATHS | MON | 11AM to 11:40AM
CLASS 8B HIST | MON | 5PM to 5:40PM\'
CLASS 8B CHEM | MON | 10AM to 10:40AM
';
$subst = "<A-WHITE-SPACE>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;