#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((\r?\n){2}|^)([^\r\n]*\|[^\r\n]*(\r?\n)?)+(?=(\r?\n){2}|$)"
Local $sString = "" & @CRLF & _
"item | test" & @CRLF & _
"------|:-----:" & @CRLF & _
"test2 | lol" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"blannlalbablabla" & @CRLF & _
"" & @CRLF & _
"item | test" & @CRLF & _
"------|:-----:" & @CRLF & _
"test2 | lol" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"test | foo" & @CRLF & _
"bla | yo" & @CRLF & _
"" & @CRLF & _
"jljhkjgkgkj"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")