import re
regex = re.compile(r"((\r?\n){2}|^)([^\r\n]*\|[^\r\n]*(\r?\n)?)+(?=(\r?\n){2}|$)", flags=re.MULTILINE)
test_str = ("\n"
"item | test\n"
"------|:-----:\n"
"test2 | lol\n\n\n"
"blannlalbablabla\n\n"
"item | test\n"
"------|:-----:\n"
"test2 | lol\n\n\n\n\n\n"
"test | foo\n"
"bla | yo\n\n"
"jljhkjgkgkj")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")