using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"TASK\s\[(?P<task_name>[A-Za-z0-9_ -]+)\]\s\*+\n(?P<host_result_block>.*?((?=^TASK\s)|(?=^PLAY\sRECAP)))";
string input = @"PLAY [Linux Hostname] **********************************************************
TASK [Gathering Facts] *********************************************************
ok: [LINUX1]
ok: [LINUX2]
fatal: [LINUX3]
TASK [Check Linux Hostname] ****************************************************
ok: [LINUX1]
PLAY RECAP *********************************************************************
LINUX1 : ok=2 changed=0 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}