use strict;
my $str = 'PLAY [Linux Hostname] **********************************************************
TASK [Gathering Facts] *********************************************************
ok: [LINUX1]
ok: [LINUX2]
fatal: [LINUX3]
TASK [Check Linux Hostname] ****************************************************
ok: [LINUX1]
PLAY RECAP *********************************************************************
LINUX1 : ok=2 changed=0 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0
';
my $regex = qr/TASK\s\[(?P<task_name>[A-Za-z0-9_ -]+)\]\s\*+\n(?P<host_result_block>.*?((?=^TASK\s)|(?=^PLAY\sRECAP)))/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}