import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "TASK\\s\\[(?P<task_name>[A-Za-z0-9_ -]+)\\]\\s\\*+\\n(?P<host_result_block>.*?((?=^TASK\\s)|(?=^PLAY\\sRECAP)))";
final String string = "PLAY [Linux Hostname] **********************************************************\n\n"
+ "TASK [Gathering Facts] *********************************************************\n"
+ "ok: [LINUX1]\n"
+ "ok: [LINUX2]\n"
+ "fatal: [LINUX3]\n\n"
+ "TASK [Check Linux Hostname] ****************************************************\n"
+ "ok: [LINUX1]\n\n"
+ "PLAY RECAP *********************************************************************\n"
+ "LINUX1 : ok=2 changed=0 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0 \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}