const regex = new RegExp('TASK\\s\\[(?P<task_name>[A-Za-z0-9_ -]+)\\]\\s\\*+\\n(?P<host_result_block>.*?((?=^TASK\\s)|(?=^PLAY\\sRECAP)))', 'gms')
const str = `PLAY [Linux Hostname] **********************************************************
TASK [Gathering Facts] *********************************************************
ok: [LINUX1]
ok: [LINUX2]
fatal: [LINUX3]
TASK [Check Linux Hostname] ****************************************************
ok: [LINUX1]
PLAY RECAP *********************************************************************
LINUX1 : ok=2 changed=0 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}