$re = '/TASK\s\[(?P<task_name>[A-Za-z0-9_ -]+)\]\s\*+\n(?P<host_result_block>.*?((?=^TASK\s)|(?=^PLAY\sRECAP)))/ms';
$str = 'PLAY [Linux Hostname] **********************************************************
TASK [Gathering Facts] *********************************************************
ok: [LINUX1]
ok: [LINUX2]
fatal: [LINUX3]
TASK [Check Linux Hostname] ****************************************************
ok: [LINUX1]
PLAY RECAP *********************************************************************
LINUX1 : ok=2 changed=0 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);