import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?:25[0-5]|2[0-4][0-9]|1?[1-9][0-9]?|10[0-9])(?:(?<!\\.)\\b|\\.))(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:(?<!\\.)\\b|\\.)){3}";
final String string = "Match on VALID IP address anywhere in string.\n"
+ "192.1683.0.1 1.1.1.256 3.2.6.2351 300.3.3.3 192.168.10.10 127.0.0.999\n"
+ "255.255.256.255 255.255.255.2555 100.0.0.1 1000.0.0.1\n"
+ "192.168.10.10\n"
+ "100.0.0.1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}