import Foundation
let pattern = #"\b(?:(?:25[0-5]|2[0-4][0-9]|1?[1-9][0-9]?|10[0-9])(?:(?<!\.)\b|\.))(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:(?<!\.)\b|\.)){3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Match on VALID IP address anywhere in string.
192.1683.0.1 1.1.1.256 3.2.6.2351 300.3.3.3 192.168.10.10 127.0.0.999
255.255.256.255 255.255.255.2555 100.0.0.1 1000.0.0.1
192.168.10.10
100.0.0.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)