$re = '/\b(?:(?:25[0-5]|2[0-4][0-9]|1?[1-9][0-9]?|10[0-9])(?:(?<!\.)\b|\.))(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:(?<!\.)\b|\.)){3}/';
$str = 'Match on VALID IP address anywhere in string.
192.1683.0.1 1.1.1.256 3.2.6.2351 300.3.3.3 192.168.10.10 127.0.0.999
255.255.256.255 255.255.255.2555 100.0.0.1 1000.0.0.1
192.168.10.10
100.0.0.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);