using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*key: (?<ref>[^:]+):(?<ver>\S+)";
string input = @"key: foo/bar:v1.2.3
key: baz/spam:1.2.3 greed";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}