re = /^\s*key: (?<ref>[^:]+):(?<ver>\S+)/m
str = 'key: foo/bar:v1.2.3
key: baz/spam:1.2.3 greed'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end