// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*key: (?<ref>[^:]+):(?<ver>\S+)").unwrap();
let string = "key: foo/bar:v1.2.3
key: baz/spam:1.2.3 greed";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}