$re = '/^\s*key: (?<ref>[^:]+):(?<ver>\S+)/m';
$str = 'key: foo/bar:v1.2.3
key: baz/spam:1.2.3 greed';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);