package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*key: (?<ref>[^:]+):(?<ver>\S+)`)
var str = `key: foo/bar:v1.2.3
key: baz/spam:1.2.3 greed`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}