using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"define ([a-zA-Z0-9- ]+?)(?:to be)";
string input = @"We define the difference of two sets A and B to be";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}