re = /define ([a-zA-Z0-9- ]+?)(?:to be)/m
str = 'We define the difference of two sets A and B to be'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end