$re = '/define ([a-zA-Z0-9- ]+?)(?:to be)/m';
$str = 'We define the difference of two sets A and B to be';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);