const regex = /define ([a-zA-Z0-9- ]+?)(?:to be)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('define ([a-zA-Z0-9- ]+?)(?:to be)', 'gm')
const str = `We define the difference of two sets A and B to be`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}