using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^molecule\/default\/tests\/test_default\.py\s\.\s*\[?(\d+)\%\]$";
string input = @"============================= test session starts ==============================
platform linux -- Python 3.9.7, pytest-6.2.5, py-1.11.0, pluggy-1.0.0
rootdir: /
plugins: testinfra-6.5.0
collected 1 item
molecule/default/tests/test_default.py . [100%]
============================== 1 passed in 37.81s ==============================
INFO Verifier completed successfully.
INFO Running default > cleanup
Molecule default > cleanup
00:00
WARNING Skipping, cleanup playbook not configured.
INFO Running default > destroy
Molecule default > destroy";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}