import Foundation
let pattern = #"^molecule\/default\/tests\/test_default\.py\s\.\s*\[?(\d+)\%\]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
============================= test session starts ==============================
platform linux -- Python 3.9.7, pytest-6.2.5, py-1.11.0, pluggy-1.0.0
rootdir: /
plugins: testinfra-6.5.0
collected 1 item
molecule/default/tests/test_default.py . [100%]
============================== 1 passed in 37.81s ==============================
INFO Verifier completed successfully.
INFO Running default > cleanup
Molecule default > cleanup
00:00
WARNING Skipping, cleanup playbook not configured.
INFO Running default > destroy
Molecule default > destroy
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)