$re = '/^molecule\/default\/tests\/test_default\.py\s\.\s*\[?(\d+)\%\]$/m';
$str = '============================= test session starts ==============================
platform linux -- Python 3.9.7, pytest-6.2.5, py-1.11.0, pluggy-1.0.0
rootdir: /
plugins: testinfra-6.5.0
collected 1 item
molecule/default/tests/test_default.py . [100%]
============================== 1 passed in 37.81s ==============================
INFO Verifier completed successfully.
INFO Running default > cleanup
Molecule default > cleanup
00:00
WARNING Skipping, cleanup playbook not configured.
INFO Running default > destroy
Molecule default > destroy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);