import re
regex = re.compile(r"^molecule\/default\/tests\/test_default\.py\s\.\s*\[?(\d+)\%\]$", flags=re.MULTILINE)
test_str = ("============================= test session starts ==============================\n"
"platform linux -- Python 3.9.7, pytest-6.2.5, py-1.11.0, pluggy-1.0.0\n"
"rootdir: /\n"
"plugins: testinfra-6.5.0\n"
"collected 1 item\n"
"molecule/default/tests/test_default.py . [100%]\n"
"============================== 1 passed in 37.81s ==============================\n"
"INFO Verifier completed successfully.\n"
"INFO Running default > cleanup\n"
"Molecule default > cleanup\n"
"00:00\n"
"WARNING Skipping, cleanup playbook not configured.\n"
"INFO Running default > destroy\n"
"Molecule default > destroy")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")