use strict;
my $str = '============================= test session starts ==============================
platform linux -- Python 3.9.7, pytest-6.2.5, py-1.11.0, pluggy-1.0.0
rootdir: /
plugins: testinfra-6.5.0
collected 1 item
molecule/default/tests/test_default.py . [100%]
============================== 1 passed in 37.81s ==============================
INFO Verifier completed successfully.
INFO Running default > cleanup
Molecule default > cleanup
00:00
WARNING Skipping, cleanup playbook not configured.
INFO Running default > destroy
Molecule default > destroy';
my $regex = qr/^molecule\/default\/tests\/test_default\.py\s\.\s*\[?(\d+)\%\]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}