#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^\s"]+) +<(?!\1)[^>]*>$"
Local $sString = "Louis Vuitton <yjfner@stangpedemc.com>" & @CRLF & _
"Louis Vuitton <yjfner@stangpedemc.com>" & @CRLF & _
"yjfner@stangpedemc.com <yjfner@stangpedemc.com>" & @CRLF & _
"ABC @ CDE <yjfner@stangpedemc.com>" & @CRLF & _
""Valid Name" <yjfner@stangpedemc.com>" & @CRLF & _
""this@example.com" <this@example.com>" & @CRLF & _
"" & @CRLF & _
"ValidName <yjfner@stangpedemc.com>" & @CRLF & _
"Valid@Name <yjfner@stangpedemc.com>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")