use strict;
my $str = 'Louis Vuitton <yjfner@stangpedemc.com>
Louis Vuitton <yjfner@stangpedemc.com>
yjfner@stangpedemc.com <yjfner@stangpedemc.com>
ABC @ CDE <yjfner@stangpedemc.com>
"Valid Name" <yjfner@stangpedemc.com>
"this@example.com" <this@example.com>
ValidName <yjfner@stangpedemc.com>
Valid@Name <yjfner@stangpedemc.com>
';
my $regex = qr/^([^\s"]+) +<(?!\1)[^>]*>$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}