re = /^([^\s"]+) +<(?!\1)[^>]*>$/m
str = 'Louis Vuitton <yjfner@stangpedemc.com>
Louis Vuitton <yjfner@stangpedemc.com>
yjfner@stangpedemc.com <yjfner@stangpedemc.com>
ABC @ CDE <yjfner@stangpedemc.com>
"Valid Name" <yjfner@stangpedemc.com>
"this@example.com" <this@example.com>
ValidName <yjfner@stangpedemc.com>
Valid@Name <yjfner@stangpedemc.com>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end