const regex = /^([^\s"]+) +<(?!\1)[^>]*>$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\s"]+) +<(?!\\1)[^>]*>$', 'gm')
const str = `Louis Vuitton <yjfner@stangpedemc.com>
Louis Vuitton <yjfner@stangpedemc.com>
yjfner@stangpedemc.com <yjfner@stangpedemc.com>
ABC @ CDE <yjfner@stangpedemc.com>
"Valid Name" <yjfner@stangpedemc.com>
"this@example.com" <this@example.com>
ValidName <yjfner@stangpedemc.com>
Valid@Name <yjfner@stangpedemc.com>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}