import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\s\"]+) +<(?!\\1)[^>]*>$";
final String string = "Louis Vuitton <yjfner@stangpedemc.com>\n"
+ "Louis Vuitton <yjfner@stangpedemc.com>\n"
+ "yjfner@stangpedemc.com <yjfner@stangpedemc.com>\n"
+ "ABC @ CDE <yjfner@stangpedemc.com>\n"
+ "\"Valid Name\" <yjfner@stangpedemc.com>\n"
+ "\"this@example.com\" <this@example.com>\n\n"
+ "ValidName <yjfner@stangpedemc.com>\n"
+ "Valid@Name <yjfner@stangpedemc.com>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}