#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\S)programming language(?![^\s.!?])|(?<!\S)programming(?![^\s.!?])|(?<!\S)language(?![^\s.!?])"
Local $sString = "A programming language is a formal language that specifies a set of instructions that can be used to produce various kinds of output. programming languages generally consist of instructions for a computer."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")