$re = '/(?<!\S)programming language(?![^\s.!?])|(?<!\S)programming(?![^\s.!?])|(?<!\S)language(?![^\s.!?])/';
$str = 'A programming language is a formal language that specifies a set of instructions that can be used to produce various kinds of output. programming languages generally consist of instructions for a computer.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);