import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)programming language(?![^\\s.!?])|(?<!\\S)programming(?![^\\s.!?])|(?<!\\S)language(?![^\\s.!?])";
final String string = "A programming language is a formal language that specifies a set of instructions that can be used to produce various kinds of output. programming languages generally consist of instructions for a computer.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}